summaryrefslogtreecommitdiff
path: root/dev-python/pypy3/pypy3-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy3/pypy3-9999.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 92c2f84f5b09..5be752f1fc4c 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -36,8 +36,16 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
)
!dev-python/pypy3-bin:0"
DEPEND="${RDEPEND}
- low-memory? ( virtual/pypy:0 )
- !low-memory? ( ${PYTHON_DEPS} )"
+ low-memory? ( virtual/pypy )
+ !low-memory? (
+ || (
+ virtual/pypy
+ (
+ dev-lang/python:2.7
+ dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
+ )
+ )
+ )"
# doc? ( dev-python/sphinx )
# Who would care about predictable directory names?