summaryrefslogtreecommitdiff
path: root/dev-python/pypy3/pypy3-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy3/pypy3-9999.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 3b0362d0252f..236616d1f286 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -92,10 +92,14 @@ src_unpack() {
}
src_prepare() {
+ eapply "${FILESDIR}/7.0.0-gentoo-path.patch"
eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
eapply "${FILESDIR}"/5.9.0-shared-lib.patch # 517002
eapply "${FILESDIR}"/7.0.0_all_distutils_cxx.patch
+ sed -e "s^@EPREFIX@^${EPREFIX}^" \
+ -i lib-python/3/distutils/command/install.py || die
+
# apply CPython stdlib patches
pushd lib-python/3 > /dev/null || die
eapply "${FILESDIR}"/python-3.5-distutils-OO-build.patch