summaryrefslogtreecommitdiff
path: root/dev-python/pypy3/pypy3-7.3.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy3/pypy3-7.3.16.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-7.3.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.16.ebuild b/dev-python/pypy3/pypy3-7.3.16.ebuild
new file mode 100644
index 000000000000..ba301054faf0
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.10
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://www.pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy310-pp73-384"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="+gdbm ncurses sqlite tk"
+
+RDEPEND="
+ =dev-python/pypy3_10-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}