summaryrefslogtreecommitdiff
path: root/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild b/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild
new file mode 100644
index 000000000000..07644e35c8be
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.10
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://www.pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy310-pp73-384"
+KEYWORDS=""
+IUSE="+gdbm ncurses sqlite tk"
+
+RDEPEND="
+ =dev-python/pypy3_10-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}