summaryrefslogtreecommitdiff
path: root/dev-python/pypy/pypy-5.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy/pypy-5.10.0.ebuild')
-rw-r--r--dev-python/pypy/pypy-5.10.0.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/pypy/pypy-5.10.0.ebuild b/dev-python/pypy/pypy-5.10.0.ebuild
index 7cfed8fcca3b..286b7be69e1d 100644
--- a/dev-python/pypy/pypy-5.10.0.ebuild
+++ b/dev-python/pypy/pypy-5.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,7 +19,7 @@ LICENSE="MIT"
# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
SLOT="0/41"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite cpu_flags_x86_sse2 test tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -39,7 +39,6 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
# don't enforce the dep on pypy with USE=low-memory since it's going
# to cause either collisions or circular dep on itself
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
!low-memory? (
|| (
dev-python/pypy
@@ -188,8 +187,6 @@ src_compile() {
cp -p "${T}"/usession*-0/testing_1/{pypy-c,libpypy-c.so} . || die
pax-mark m pypy-c libpypy-c.so
- use doc && emake -C pypy/doc html
-
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.
@@ -262,9 +259,6 @@ src_install() {
"${ED%/}${dest}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
fi
- # Install docs
- use doc && dodoc -r pypy/doc/_build/html
-
local -x PYTHON=${ED%/}${dest}/pypy-c
# we can't use eclass function since PyPy is dumb and always gives
# paths relative to the interpreter