summaryrefslogtreecommitdiff
path: root/dev-python/pypugjs/pypugjs-5.9.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypugjs/pypugjs-5.9.9.ebuild')
-rw-r--r--dev-python/pypugjs/pypugjs-5.9.9.ebuild34
1 files changed, 27 insertions, 7 deletions
diff --git a/dev-python/pypugjs/pypugjs-5.9.9.ebuild b/dev-python/pypugjs/pypugjs-5.9.9.ebuild
index f5142600ec46..c8ca907dcf5c 100644
--- a/dev-python/pypugjs/pypugjs-5.9.9.ebuild
+++ b/dev-python/pypugjs/pypugjs-5.9.9.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+EAPI=8
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
HOMEPAGE="https://github.com/kakulukia/pypugjs"
@@ -15,9 +14,30 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
-IUSE=""
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
- dev-python/chardet
+ dev-python/chardet[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # Remove pyramid backend as pyramid isn't packaged
+ rm -r pypugjs/ext/pyramid || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "converting to Django output" dev-python/django
+ optfeature "converting to Jinja2 output" dev-python/jinja
+ optfeature "converting to Mako output" dev-python/mako
+ optfeature "converting to Tornado output" www-servers/tornado
+}