summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-fmt/pyproject-fmt-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproject-fmt/pyproject-fmt-1.7.0.ebuild')
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.7.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-1.7.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.7.0.ebuild
deleted file mode 100644
index 7da8128f9cf9..000000000000
--- a/dev-python/pyproject-fmt/pyproject-fmt-1.7.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Format your pyproject.toml file"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-fmt/
- https://pypi.org/project/pyproject-fmt/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/natsort[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
-"
-# tox is called as a subprocess, to get targets from tox.ini
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- dev-python/tox
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream lower bounds are completely meaningless and copying them
- # to the ebuild is a horrible waste of time
- sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
- distutils-r1_src_prepare
-}