summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-api/pyproject-api-1.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproject-api/pyproject-api-1.1.2.ebuild')
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.1.2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pyproject-api/pyproject-api-1.1.2.ebuild b/dev-python/pyproject-api/pyproject-api-1.1.2.ebuild
deleted file mode 100644
index bbb1f43c5b49..000000000000
--- a/dev-python/pyproject-api/pyproject-api-1.1.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="API to interact with the python pyproject.toml based projects"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-api/
- https://pypi.org/project/pyproject-api/
-"
-SRC_URI="
- https://github.com/tox-dev/pyproject-api/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.2[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.37.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}