summaryrefslogtreecommitdiff
path: root/dev-python/pyproj/pyproj-1.9.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproj/pyproj-1.9.5.1-r1.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-1.9.5.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyproj/pyproj-1.9.5.1-r1.ebuild b/dev-python/pyproj/pyproj-1.9.5.1-r1.ebuild
new file mode 100644
index 000000000000..e7e486903c9f
--- /dev/null
+++ b/dev-python/pyproj/pyproj-1.9.5.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python interface to PROJ.4 library"
+HOMEPAGE="https://github.com/jswhit/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ append-cflags -fno-strict-aliasing
+}
+
+python_test() {
+ "${EPYTHON}" unittest/test.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}