summaryrefslogtreecommitdiff
path: root/dev-python/pyphen/pyphen-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyphen/pyphen-0.10.0.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.10.0.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-python/pyphen/pyphen-0.10.0.ebuild b/dev-python/pyphen/pyphen-0.10.0.ebuild
index 99764ca32724..37507a56effb 100644
--- a/dev-python/pyphen/pyphen-0.10.0.ebuild
+++ b/dev-python/pyphen/pyphen-0.10.0.ebuild
@@ -1,30 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
-MY_PN="Pyphen"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="https://github.com/Kozea/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
distutils_enable_tests pytest
python_test() {
- pytest -v test.py || die
+ epytest test.py
}