summaryrefslogtreecommitdiff
path: root/dev-python/pyparted/pyparted-3.11.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyparted/pyparted-3.11.3.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.11.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.11.3.ebuild b/dev-python/pyparted/pyparted-3.11.3.ebuild
new file mode 100644
index 000000000000..97c6d6e4d2b7
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.11.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/rhinstaller/pyparted/"
+SRC_URI="https://github.com/rhinstaller/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT="test"