summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyotherside')
-rw-r--r--dev-python/pyotherside/Manifest3
-rw-r--r--dev-python/pyotherside/metadata.xml5
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.3.ebuild40
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
new file mode 100644
index 000000000000..b3db8e23b527
--- /dev/null
+++ b/dev-python/pyotherside/Manifest
@@ -0,0 +1,3 @@
+DIST pyotherside-1.5.3.tar.gz 181811 BLAKE2B ce2b7c4b9490e3d30e0e8a3911907fe3ab5aa9f812d29cf4f633957d5ade5261ab7e3691751b0bc696459080089dfec0439b970ac7ad0bd36aa22eb0c9c87112 SHA512 ff6aa43e72f5492b18403559514e6fdf0d2cee0965556fcafe5fe394b654a7dd2fc3a7d64d4b8f9c0ebf95485821b77022407772b2414539f2ab287e1fb01e93
+EBUILD pyotherside-1.5.3.ebuild 742 BLAKE2B fe2175b3bf0bbd4d74f4634c90777f93f99fef35d595dbcb100cbdbe72f1dfe6af1e294b046ea129a9369019a3374a11e077ef5ff9100faddfc1e5f88fede53c SHA512 2b11146d25fc9d6358fb32efea4404581fbd4789caf4cd7fb917fd6c676bb0e8e21a0c63bcbd6c290a5cf01fa5180f0a7e269eb34f2d644f236e30393da905a3
+MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/dev-python/pyotherside/metadata.xml b/dev-python/pyotherside/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/dev-python/pyotherside/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/dev-python/pyotherside/pyotherside-1.5.3.ebuild b/dev-python/pyotherside/pyotherside-1.5.3.ebuild
new file mode 100644
index 000000000000..73bb95ee4f22
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}