summaryrefslogtreecommitdiff
path: root/dev-python/pyopengl/pyopengl-3.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopengl/pyopengl-3.1.7.ebuild')
-rw-r--r--dev-python/pyopengl/pyopengl-3.1.7.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-python/pyopengl/pyopengl-3.1.7.ebuild b/dev-python/pyopengl/pyopengl-3.1.7.ebuild
index 223b4939eb29..52f90ccbfbbf 100644
--- a/dev-python/pyopengl/pyopengl-3.1.7.ebuild
+++ b/dev-python/pyopengl/pyopengl-3.1.7.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=PyOpenGL
PYTHON_REQ_USE="tk?"
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi virtualx
@@ -49,6 +49,20 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/mcfletch/pyopengl/commit/b49af26c615236ebc29cf125a8315091482a4a2a
+ "${FILESDIR}/${P}-py312.patch"
+)
+
+EPYTEST_DESELECT=(
+ # unreliable memory counting test
+ tests/test_vbo_memusage.py::test_sf_2980896
+)
+
+python_test() {
+ nonfatal epytest || die "Tests failed with ${EPYTHON}"
+}
+
src_test() {
virtx distutils-r1_src_test
}