summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest4
-rw-r--r--dev-python/pyopencl/pyopencl-2021.1.3.ebuild57
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.6.ebuild2
3 files changed, 2 insertions, 61 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 7e7e68fb9349..d6afa049fa69 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,5 +1,3 @@
-DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
DIST pyopencl-2021.2.6.tar.gz 450194 BLAKE2B be9d0bf653f77d33a4337deab9189a5a9031ff50526444283c6fb9f8625d0451cb211ff703b5eb86c18beebb973f8f7a7cc93da3efc6bb4e95cd533d633fde93 SHA512 b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c
-EBUILD pyopencl-2021.1.3.ebuild 1491 BLAKE2B 627fcf87c2a199260cb4697729d7fffe01dd0da7e0146fe6c981a7e2673c97496bfb1d90fd5c7354b64bb7a7f871d46b692855db6111f9cb4f559595de0f90f0 SHA512 820bbe51273f64d1f5aa2e781e68baebbc6ebe014b281b3c477876442e9a218d3cdad26b693aaacf48fba07df450d4c754b7356c140c553de9e6908b6af6447e
-EBUILD pyopencl-2021.2.6.ebuild 1405 BLAKE2B 68d74cea97af5cdaf30ab8ec8305410f1b9cb64bc5763429111c0a818e7da8ecad1de916779acc8f4a2ee0b1195205938d325a61cc5a55ec31eb0fe685d8742f SHA512 99ae298854a27a57682f2932b952d5e0b34f0c5a7056bccc06169a37421304bcd9e5a2232ddd730f83018a1f46a5e07ce7926bee7e51ff96f46b5019eb5a87d4
+EBUILD pyopencl-2021.2.6.ebuild 1404 BLAKE2B 3db690ddda606ff83eba51220b40a148da79f75b91e26586e7c8c4e726888821e5181f1742662206eedfeba8defc7bae36547ed2955512b8f1bf6a818a38719f SHA512 f14f35bf7be814dca5e424c25493f6cd94aa40f008e3ed66e073eb628f76ac7417f8e7433eef488242ea61a37760e5fe45595c097c17dac73b3b8b34a6390f46
MISC metadata.xml 316 BLAKE2B 46de5d09541dbd7e1ae6cb3e46a87f0f7dde068ca48dfb4f8885b3f25a2c6ad258019a7585bc6dac42a01ce41292d5458aa7ba122fd81a1fe6f12307b0642966 SHA512 1ac69571c5ff5abb94dc68dc87d02d8675e12e120dedb0bece65a9cb81764f496a587e7345b43e8037f8d7ed6e269dfa276d8482ab42fdb4f3adda336570d703
diff --git a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
deleted file mode 100644
index 103b128915c0..000000000000
--- a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples opengl"
-
-COMMON="dev-python/numpy[${PYTHON_USEDEP}]
- >=virtual/opencl-2"
-RDEPEND="${COMMON}
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]
- opengl? ( media-libs/libglvnd )"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopencl/pyopencl-2021.2.6.ebuild b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
index 9c4b6ac92a78..153702aea574 100644
--- a/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
+++ b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="examples opengl"
COMMON="dev-python/numpy[${PYTHON_USEDEP}]