summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest4
-rw-r--r--dev-python/pyopencl/pyopencl-2023.1.4.ebuild72
-rw-r--r--dev-python/pyopencl/pyopencl-2024.1.ebuild2
3 files changed, 2 insertions, 76 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index eea43c4251c2..177ec1507f9d 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,5 +1,3 @@
-DIST pyopencl-2023.1.4.tar.gz 473899 BLAKE2B 7d836d77b14f89b6dbf0dd2a189f3cb9442f224ff5c9c9db902aa93dc582278450b3d47576885bbe3738ee25f979a260d5c6f906366279adc30be7d3cc3545e1 SHA512 2508d21856d9b846bce14bcd11d007eedddc1cc5c1ce9f8d2ac18743ab9aa5d673c85792b535779b2f414caf47e39ed53c07d7ee8a061bcfa020a15f59463861
DIST pyopencl-2024.1.tar.gz 473860 BLAKE2B 803c92418a609f3ad9249c81e93af0bd2e9125ee56dc88af8ee6ae9c4a275c7ab37befddd575914eb9f0b295aaef4f135358669e384a55c04b3938b02572724d SHA512 abf27d67f8c3633c71e662938a919c88a34b0b66cc3c213644f92a8733aed3c9b7593542dd9b45a080941976dadeb4f49a23a986482110824b554e3a0d317176
-EBUILD pyopencl-2023.1.4.ebuild 2023 BLAKE2B 6c4b917ea87686fb82954e8a0e86827fde43b106982b91bc4cbb35e0825b6896cc4c2bfc50248e20bbab909a6f6e75e1ebfe68341e3d32253749cd56b619c787 SHA512 c8b68a2c9761f64e49786df1613c6547596ed5624249a5413565d3a64487dee97fb911b2411fd30b58af8b81e49709a6c1d5e9d30b251b3f6a60fc17201c4b20
-EBUILD pyopencl-2024.1.ebuild 2024 BLAKE2B 946bafdb521ffd1fa0dbd96841f076796947b76847a4e0283c1de86adec783a4a741cec44e2b992ea52fc3393a92b9b45ebb05869488dd7c9dcffbb79b8e8c3b SHA512 45e5d18bbd7ad25aee16285ef5e952d87aa072d02b297b9829166e7e55d03d09f125ea604b5dab0067625e1559f6cac522951010c573508576eaaffeb2fb77fa
+EBUILD pyopencl-2024.1.ebuild 2023 BLAKE2B 6088a13394451d8ce78f521fb3dfde49ae96df2be6444c60d176203a252e5220b9d23b855adbd552606c1f6a612541eb49f1d85b313baa96814b202e74ec6c60 SHA512 84fa66010684576ea2c62f2d72f85d64a9ca561b90aa3ed9c51fce39e605bbf71d9532d45b3c6dfbc199ad9e245c4a14223947aff3235608511c83d1ccdde27a
MISC metadata.xml 373 BLAKE2B 0de89cb91a5dba1c34bacf04a95d4e2eb9e903bfb55e291f2ed20d579b9736a9a25f27620eed05d19c903c117e0dfbf410f408e9ff4008ce8c93f7b1b004141e SHA512 4ff5643089e5590d1ae4ef413a1ab0fa2772f71922a9da2c8b43ae375ba2e6e3d95ab90a13d51d22fdea49663c112c36352df609eceebd520fdc06590907b0e7
diff --git a/dev-python/pyopencl/pyopencl-2023.1.4.ebuild b/dev-python/pyopencl/pyopencl-2023.1.4.ebuild
deleted file mode 100644
index 2c2f1d602dd2..000000000000
--- a/dev-python/pyopencl/pyopencl-2023.1.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="
- https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-IUSE="examples opengl"
-
-# Running tests on GPUs requires both appropriate hardware and additional permissions
-# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
-# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
-RESTRICT="test"
-
-COMMON=">=virtual/opencl-2"
-# libglvnd is only needed for the headers
-DEPEND="${COMMON}
- opengl? ( media-libs/libglvnd )"
-RDEPEND="${COMMON}
- >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- test? ( dev-libs/pocl )"
-
-distutils_enable_tests pytest
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_test() {
- # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
- local -x PYOPENCL_TEST="portable:pthread"
- # Set the number of threads to match MAKEOPTS
- local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
- # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
- # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
- pushd test >/dev/null || die
- epytest
- popd >/dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopencl/pyopencl-2024.1.ebuild b/dev-python/pyopencl/pyopencl-2024.1.ebuild
index 30bcf1530b3a..0cb03a72953a 100644
--- a/dev-python/pyopencl/pyopencl-2024.1.ebuild
+++ b/dev-python/pyopencl/pyopencl-2024.1.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~riscv"
+KEYWORDS="amd64 ~ppc64 ~riscv"
IUSE="examples opengl"
# Running tests on GPUs requires both appropriate hardware and additional permissions