summaryrefslogtreecommitdiff
path: root/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild')
-rw-r--r--dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild b/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..b2b6ecd0a450
--- /dev/null
+++ b/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Python bindings for libnest2d"
+HOMEPAGE="https://github.com/Ultimaker/pynest2d"
+SRC_URI="https://github.com/Ultimaker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libnest2d
+ $(python_gen_cond_dep 'dev-python/sip[${PYTHON_MULTI_USEDEP}]')
+ "
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-required-flags-from-Libnest2D-target.patch
+ "${FILESDIR}"/${P}-fix-cpp-version.patch
+)