summaryrefslogtreecommitdiff
path: root/dev-python/pymountboot/pymountboot-0.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymountboot/pymountboot-0.2.2.ebuild')
-rw-r--r--dev-python/pymountboot/pymountboot-0.2.2.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/pymountboot/pymountboot-0.2.2.ebuild b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
index bd534a02f4e3..c5007a5efda2 100644
--- a/dev-python/pymountboot/pymountboot-0.2.2.ebuild
+++ b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
inherit distutils-r1
@@ -17,8 +19,3 @@ IUSE=""
RDEPEND=">=sys-apps/util-linux-2.20"
DEPEND="${RDEPEND}"
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}