summaryrefslogtreecommitdiff
path: root/dev-python/pymongo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest2
-rw-r--r--dev-python/pymongo/pymongo-4.2.0.ebuild121
2 files changed, 123 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 7e53da5c08b0..e672d72d0793 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,7 +1,9 @@
DIST mongo-python-driver-4.0.2.tar.gz 1027101 BLAKE2B d95eea08e09101f1db5df5dcbd5d843273ebd0c63b228420748a1663620ea18e05853372e876abc8b6480238de2b035c4e5a3c9f9b7c206228870a66e5d5f053 SHA512 eacb24d110de645a70b16b4d11f7a6b019f741fba2222f8ecee47d9f638fd71e579d3a46f5f539bc89d1ea53ddf0b72745b667a0f05479bb4b53ed72fb075b5b
DIST mongo-python-driver-4.1.0.tar.gz 1069416 BLAKE2B ea7d81e405f4db4ec0e03591909541f5452f516d359e42fc6fde74435899353f4718b7dbfe3dc1802e79c9277fcfe6203ecd33a5e2ad2682c604b9de44c46c7c SHA512 558d321a335742fc3399e9f5cb4917605353f55a1912f9fa34ac46f6107ed6522f952dc9ef584f4cbe1ffcfc600b49963a4bdf606146c38b94379bbb6a382202
DIST mongo-python-driver-4.1.1.tar.gz 1070349 BLAKE2B 9b792343a22c4b0c625376e6f3d10e9c1a88442b63ff2638c29588a26755006507189bf40a8dad96d7f8e4f997efc153c8616826b58114aba32442c05b80ca60 SHA512 b01eb6bc4c39a25cae8350bdc2f37dd5d78da38a6eddbd8a26f91cb6ee067f7b4b1d97eb603defca16e05abc992b8f11b2e3558f9697c99697b3e876838de737
+DIST mongo-python-driver-4.2.0.gh.tar.gz 1136734 BLAKE2B b3e2d86780c2874656f94ba3071317c0b9190418274c163135a260cad3f5672b9390aa738d0cf1aaff47412827620706e67c5c990910a5ea232aaacda0758dea SHA512 4439149c35f897a61109b26f5e4c613682ca59727495377a3bbb49f9ff22273cd5a73f58fb55080d07c9403310d4ada59d3a5969d0f76f2f4d1081422fe2dfec
EBUILD pymongo-4.0.2.ebuild 2762 BLAKE2B 55e8e7d00cb2cc710cfe9577e18641964d74e670f89e123ed07a83bee69e2a7292eaae5eea8e75a6201efac6068648fbd831a54d74f430d03bf2088ae65fbc91 SHA512 c6e62e89a90ed45763cb0f679bae97187062cdcf4d22bd199f2ed1d24617648ff383cf8e3401add6b188ca4526ad1020b25951c6381b833ab98115bc3326027b
EBUILD pymongo-4.1.0.ebuild 2765 BLAKE2B 9e0daa5786bfcdd3997d91dc81d73edf1c3cce0c9e72a4e9e957940079b6c1d37c09f0ca9f52a02e7dd4cb36ca5ddcb0f36b8848b049dbb2f6727d44139e5230 SHA512 90c9917a2c760694bf8f82632a35c7a56974bb2a6e45d27677aacf5487ec4da55705bcf9cfe88935170bc25d69d820eba24834bc22857c2689acec1457ad2b1b
EBUILD pymongo-4.1.1.ebuild 2763 BLAKE2B 131597592b3f0a719a02b25b0af93b23a9965ba7c93a62a0c35846d6dbb1cc1b3ff19a829262f199b0edd3079152e4169899bf0b120092576f9ecb29e9947bc2 SHA512 a13e5fe063d42c3f98af5f28ab0147e87dbb7108a9a72130405af6a5196cc4d14433ab52f1d3cffdc87544045bc8d7f12acd79848a9c22b91125daf544cb6273
+EBUILD pymongo-4.2.0.ebuild 2774 BLAKE2B 4fa93e4f16e41591a43227739ee3770c3257a9905c42497083ca2ca0350c18218ddc2fbb98037617a562615dc3ba5c80a82bb5a5dafeb5539bde66634007a26e SHA512 05a59ba2f518af45476ccdeb6523e1f8dd8d25cc66401cb3d39efe8e4ec09a4f3bb8b3eecb63986198b4413d30b867e3eded2ec7f1d7fce353a2b8c2a928a849
MISC metadata.xml 673 BLAKE2B fb66f76592841f2647a94e24e07fafa8be2bc31583bac35dc3933a3feeea87f0c4105ab6b480bce5f2b8aeced8c113c8a3ce9714b22ff909f92eccceffa8f9a9 SHA512 9e758aa60153da583ed21bdf6addd001c560894fc6d429217405e7dfbdc673a9e22bc5a41afcc1281f7613ae1059c0824a7bba246006aa66c6eced75ab975e51
diff --git a/dev-python/pymongo/pymongo-4.2.0.ebuild b/dev-python/pymongo/pymongo-4.2.0.ebuild
new file mode 100644
index 000000000000..16be1870a95e
--- /dev/null
+++ b/dev-python/pymongo/pymongo-4.2.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="
+ https://github.com/mongodb/mongo-python-driver/
+ https://pypi.org/project/pymongo/
+"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+IUSE="doc kerberos"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ >=dev-db/mongodb-2.6.0
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+src_prepare() {
+ # network-sandbox
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -e 's:test_service_name_from_kwargs:_&:' \
+ -e 's:test_srv_max_hosts_kwarg:_&:' \
+ -i test/test_client.py || die
+ sed -e '/SRV_SCHEME/s:_HAVE_DNSPYTHON:False:' \
+ -i test/test_uri_spec.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}