summaryrefslogtreecommitdiff
path: root/dev-python/pymongo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest4
-rw-r--r--dev-python/pymongo/pymongo-4.5.0.ebuild152
-rw-r--r--dev-python/pymongo/pymongo-4.6.0.ebuild2
3 files changed, 2 insertions, 156 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 3d32707b0211..beb1a713a4ce 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,7 +1,5 @@
-DIST mongo-python-driver-4.5.0.gh.tar.gz 1481970 BLAKE2B fcb019042b6447093e1cfb9d66514954c31a26322060842b3c8e93d865f74db356004c6d7090d1a535d1ce523513cbd9e7935c7ee7655cdd47691d1b7ede97f0 SHA512 eb607f692c28daacef436e7649b3265465f8f785a68b29eda16b5ab5d926d0fa4737bcc6974f54778794dfd7fbcd95c30478867d6479ea45d412f2404cb2aa30
DIST mongo-python-driver-4.6.0.gh.tar.gz 1493605 BLAKE2B 088e5d222d64b00f5849435dadf116e51d00bc89c1f25371972256a342df434f068103affc001635138d7a55f9a5d22152cc3b58ef5317e1e39607390c027eb8 SHA512 348dd08c4a64e1f65fd49961b97b3779aa505421359a1f22a2030c9e87248c50eb10fcf39039b10185808dfe693beee3a3c953d09657b3ccfc22875a377240bd
DIST mongo-python-driver-4.6.1.gh.tar.gz 1493790 BLAKE2B dd59001536ed5d84553350fe8c93fa5082acd1af23ca2850cb2ba8d69e1e69e2ad250da9f62b4f86e6e9013434cd1d2ed38e44bda946ff5fe0ab74935668bbf1 SHA512 7a6fe18b409961b796dfd403dc100a898b282e0abfd9995f20541b7c5f0f2dbc047c25b45a2bb9ae229954d1cd804918dc4f7487f87e311863452bab41a19414
-EBUILD pymongo-4.5.0.ebuild 4261 BLAKE2B 9cc1a20fae4a69e5d388af6e748f2e94ae828a2943a9b97c91b8fc89db7f4c60079af05485aa75b21c5a89447a3d1184d139941ec1d9ef97ef659b79073ee19f SHA512 435cade51d1c11381d9772e2a2993084800463a61ef2b80bb3e5e97dcb3676628f0df005d0a41feb9b87c2028d6105785b34824d5cbe4c265acd15159f5c3666
-EBUILD pymongo-4.6.0.ebuild 4323 BLAKE2B f436eafea0249c931bbc07be4ff268687f13c36ad5c1547b0f32fa821156502dc245549e07bdcdeba9d4ca6a50b02a8e789da910abd48856852d2d216dd362cd SHA512 a5cfa0035038bcfbf53c61c8f5c83dde21c4392b59afbf38de42f5bdcf15130a9e7fa85cbb7986c996dfdafb49b366c6020e52f91e366b5ff840a38137391581
+EBUILD pymongo-4.6.0.ebuild 4322 BLAKE2B 2c0120c5d55963fce6b12d16d392e3422666aa272c149ef455df35303087f9c7d703e1c9a6c205b1978ff0680902456dbedeb5a55356b33cbded2895fee9d2ce SHA512 a7d47df05291900f59e328219bd7a97135215a30cfc086f6eb16154dadd31071eb0e1e01154d1341a3144239fd17bdcf6297df56f7307f40514831aaf71813fa
EBUILD pymongo-4.6.1.ebuild 4327 BLAKE2B 54981aac86ca9f88793b6448f21962f21b1853b638ccdb099a667c4cad43cc8950ba1784fd6f469efad4ef8449140900a60242ab4defe744d38c88bd06485ec2 SHA512 000b60f126b03e1d519c9ce93827562519519e694163f1a8814d4db003f757111d2dd0d1eca653b547f5f04cb64dfb2a18195cae6fbfe0280f59833f6dd57db1
MISC metadata.xml 880 BLAKE2B 024d83cdf3d8cf94cdc98153a6b429550579d494b053becfe5cda0a7a7f3852632d7155e71116a9ab751e6542fe63985755f4eeb147914bc8dbb1e9fac560434 SHA512 c6110fd18fa7f7819299b5de919bfc0ce407d653115d34d297513ce3a4acd2e16399d6f327c61bc5d4ef8aa6776f84750cff37798415ca4bd59c6fd19961d891
diff --git a/dev-python/pymongo/pymongo-4.5.0.ebuild b/dev-python/pymongo/pymongo-4.5.0.ebuild
deleted file mode 100644
index 15a7a463670b..000000000000
--- a/dev-python/pymongo/pymongo-4.5.0.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit check-reqs distutils-r1
-
-MY_P=mongo-python-driver-${PV}
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="
- https://github.com/mongodb/mongo-python-driver/
- https://pypi.org/project/pymongo/
-"
-SRC_URI="
- https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="doc kerberos +native-extensions +test-full"
-
-RDEPEND="
- <dev-python/dnspython-3.0.0[${PYTHON_USEDEP}]
- kerberos? ( dev-python/kerberos[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- test-full? (
- >=dev-db/mongodb-2.6.0
- )
- )
-"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-reqcheck() {
- if use test && use test-full; then
- # During the tests, database size reaches 1.5G.
- local CHECKREQS_DISK_BUILD=1536M
-
- check-reqs_${1}
- fi
-}
-
-pkg_pretend() {
- reqcheck pkg_pretend
-}
-
-pkg_setup() {
- reqcheck pkg_setup
-}
-
-python_compile() {
- # causes build errors to be fatal
- local -x TOX_ENV_NAME=whatever
- local DISTUTILS_ARGS=()
- # unconditionally implicitly disabled on pypy3
- if ! use native-extensions; then
- DISTUTILS_ARGS+=( --no_ext )
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- rm -rf bson pymongo || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local EPYTEST_DESELECT=(
- # network-sandbox
- test/test_client.py::ClientUnitTest::test_connection_timeout_ms_propagates_to_DNS_resolver
- test/test_client.py::TestClient::test_service_name_from_kwargs
- test/test_client.py::TestClient::test_srv_max_hosts_kwarg
- test/test_dns.py::TestCaseInsensitive::test_connect_case_insensitive
- test/test_srv_polling.py
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_custom_srvServiceName
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_invalid_type_for_srvMaxHosts
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_negative_integer_for_srvMaxHosts
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_positive_srvMaxHosts_and_loadBalanced=fa
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_srvMaxHosts
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_srvMaxHosts=0_and_loadBalanced=true
- test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_srvMaxHosts=0_and_replicaSet
-
- # broken regularly by changes in mypy
- test/test_typing.py::TestMypyFails::test_mypy_failures
- )
-
- if ! use test-full; then
- # .invalid is guaranteed to return NXDOMAIN per RFC 6761
- local -x DB_IP=mongodb.invalid
- epytest
- return
- fi
-
- # Yes, we need TCP/IP for that...
- local -x DB_IP=127.0.0.1
- local -x DB_PORT=27000
-
- local dbpath=${TMPDIR}/mongo.db
- local logpath=${TMPDIR}/mongod.log
-
- # Now, the hard part: we need to find a free port for mongod.
- # We're just trying to run it random port numbers and check the log
- # for bind errors. It shall be noted that 'mongod --fork' does not
- # return failure when it fails to bind.
-
- mkdir -p "${dbpath}" || die
- while true; do
- ebegin "Trying to start mongod on port ${DB_PORT}"
-
- LC_ALL=C \
- mongod --dbpath "${dbpath}" --nojournal \
- --bind_ip ${DB_IP} --port ${DB_PORT} \
- --unixSocketPrefix "${TMPDIR}" \
- --logpath "${logpath}" --fork \
- && sleep 2
-
- # Now we need to check if the server actually started...
- if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
- # yay!
- eend 0
- break
- elif grep -q 'Address already in use' "${logpath}"; then
- # ay, someone took our port!
- eend 1
- : $(( DB_PORT += 1 ))
- continue
- else
- eend 1
- eerror "Unable to start mongod for tests. See the server log:"
- eerror " ${logpath}"
- die "Unable to start mongod for tests."
- fi
- done
-
- local failed
- nonfatal epytest || failed=1
-
- mongod --dbpath "${dbpath}" --shutdown || die
-
- [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
-
- rm -rf "${dbpath}" || die
-}
diff --git a/dev-python/pymongo/pymongo-4.6.0.ebuild b/dev-python/pymongo/pymongo-4.6.0.ebuild
index 5f1659bdbb13..195067c758b5 100644
--- a/dev-python/pymongo/pymongo-4.6.0.ebuild
+++ b/dev-python/pymongo/pymongo-4.6.0.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86"
IUSE="doc kerberos +native-extensions +test-full"
RDEPEND="