summaryrefslogtreecommitdiff
path: root/dev-python/pylzma/pylzma-0.4.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylzma/pylzma-0.4.9.ebuild')
-rw-r--r--dev-python/pylzma/pylzma-0.4.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pylzma/pylzma-0.4.9.ebuild b/dev-python/pylzma/pylzma-0.4.9.ebuild
new file mode 100644
index 000000000000..a1f58e4d416f
--- /dev/null
+++ b/dev-python/pylzma/pylzma-0.4.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the LZMA compression library"
+HOMEPAGE="http://www.joachim-bauch.de/projects/python/pylzma/ https://pypi.python.org/pypi/pylzma"
+# pypi tarball does not include test data
+SRC_URI="https://github.com/fancycode/pylzma/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=(doc/USAGE.md README.md)
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}