summaryrefslogtreecommitdiff
path: root/dev-python/pyls-spyder/pyls-spyder-0.4.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyls-spyder/pyls-spyder-0.4.0-r2.ebuild')
-rw-r--r--dev-python/pyls-spyder/pyls-spyder-0.4.0-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyls-spyder/pyls-spyder-0.4.0-r2.ebuild b/dev-python/pyls-spyder/pyls-spyder-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..70fdf0b5e5cb
--- /dev/null
+++ b/dev-python/pyls-spyder/pyls-spyder-0.4.0-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Spyder extensions for the python language server"
+HOMEPAGE="https://github.com/spyder-ide/pyls-spyder
+ https://pypi.org/project/pyls-spyder/"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-lsp-server[all-plugins,${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest