summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-3.2.5.ebuild93
-rw-r--r--dev-python/pylint/pylint-3.2.6.ebuild2
3 files changed, 2 insertions, 97 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 691e738e5bb1..23c40bcfde5c 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-3.2.5.gh.tar.gz 1446535 BLAKE2B fdc88c7873868b1cb689158d014c51a14be9200715ad2f870cc7f8703e1e29881d04092c5e49fd043d54b31258b25d0c0f40cb81cd50c0603835a67197b29d85 SHA512 bba78776ae2610456ecfecffd9571712c13c38006de19d569aaf11bdeee978e1ad33b09ce64288fb2ebccd76d76a788a8db39209cf3f9963d8a38a43605bcbaa
DIST pylint-3.2.6.gh.tar.gz 1447684 BLAKE2B 22ec600b327b405dfdd7a9ffe94b20faeed6cca92dbfff8e96baa6bebe5c049b90da55f16e84e53d4a22fdbcb5a8caf7719038935522235ccf3364fe2492c16c SHA512 ba7e87f3eaca088b88cec35ae8d1dbd15ec2167a615638b1fe7c1abb711d54742e5fb2d2c9c2836294c464b98ec32d53efaf5afb170d4cb73dacf966dddca62c
-EBUILD pylint-3.2.5.ebuild 2472 BLAKE2B d777e357935bbb5100e5ca1a5d84b9292ecad6991414717cb5e8de348d2316d6a16c4d524bf10808cf0ba4a497970ef747367e473cfb82f71d060b10aebfc2b0 SHA512 e3a518d99d77b327cf785f1ab2bc8f6683bda2935c6c5e4493f624354fde276448c16b2baaedda93d509619f0d832db76ccb19360b8d413c3e0e1a359347a642
-EBUILD pylint-3.2.6.ebuild 2480 BLAKE2B 4592da1a6cacf202f30c50b89d4a784be55af34eda8be8a33a7ad4f032c2040182fb15674b68c59fa0778d2cfb6d90854908cadf4144bd4af6e4eeaa88dd7202 SHA512 f82fca8b871f0ec35d4637f3751e64457bc3ddbda3e1a924db7ec3394ea96f02520f57cc1265ba413673c70a126ad8ad496b41acf8eead7557a29e1a0b4139fb
+EBUILD pylint-3.2.6.ebuild 2472 BLAKE2B f30bf4f6bed1d4be4434d47c1d520f77577e9890d4ff4cb016bc74e3c525b750c785e2afc5c28e79ffe5da26f3ef4f931451b5b105dd115f931e99288e7d3114 SHA512 5d9b901066a3766da9c353f406e68964e5f04dc61a5453511ac724ef94de74308137d5349be201625c347dd24574a8601da9fcda2e95f92b471d166129a21183
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.2.5.ebuild b/dev-python/pylint/pylint-3.2.5.ebuild
deleted file mode 100644
index 631d265238d7..000000000000
--- a/dev-python/pylint/pylint-3.2.5.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-3.3[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.2.2[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- ' 'python*' )
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[recursion_error_3159]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- 'tests/test_functional.py::test_functional[use_yield_from]'
- 'tests/test_functional.py::test_functional[wrong_import_order]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- if ! has_version "dev-python/GitPython[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/profile/test_profile_against_externals.py
- tests/testutils/_primer/test_package_to_lint.py
- tests/testutils/_primer/test_primer.py
- )
- fi
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-3.2.6.ebuild b/dev-python/pylint/pylint-3.2.6.ebuild
index 0cd2ec935a5d..3c913a57bc22 100644
--- a/dev-python/pylint/pylint-3.2.6.ebuild
+++ b/dev-python/pylint/pylint-3.2.6.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
RDEPEND="