summaryrefslogtreecommitdiff
path: root/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch')
-rw-r--r--dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
new file mode 100644
index 000000000000..f4cc6be360de
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
@@ -0,0 +1,20 @@
+diff --git a/setup.py b/setup.py
+index 92d059ff..cbc5b881 100644
+--- a/setup.py
++++ b/setup.py
+@@ -67,7 +67,6 @@ else:
+
+
+ needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv)
+-pytest_runner = ["pytest-runner"] if needs_pytest else []
+
+
+ def ensure_scripts(linux_scripts):
+@@ -151,7 +150,6 @@ def install(**kwargs):
+ extras_require=extras_require,
+ test_suite="test",
+ python_requires=">=3.5.*",
+- setup_requires=pytest_runner,
+ tests_require=["pytest"],
+ **kwargs
+ )