summaryrefslogtreecommitdiff
path: root/dev-python/pyldap
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyldap')
-rw-r--r--dev-python/pyldap/Manifest3
-rw-r--r--dev-python/pyldap/metadata.xml17
-rw-r--r--dev-python/pyldap/pyldap-2.4.37.ebuild76
3 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/pyldap/Manifest b/dev-python/pyldap/Manifest
new file mode 100644
index 000000000000..90a5fe99233c
--- /dev/null
+++ b/dev-python/pyldap/Manifest
@@ -0,0 +1,3 @@
+DIST pyldap-2.4.37.tar.gz 303732 BLAKE2B a3b54b172701c2e52a9bd54745d442634b8df2f4aab134d37bf5dbc383498fbec876e12c1c703db6caeac0ce3b4bccd974b0680356e5996e327c8ac2ce52ac4c SHA512 da66669bf9eecebc8ba05ee313453b151a01147bc44c60da4936b80777ec3b69551f77be0e6f3c260dba771920d50fa6f54f1892eb0283761beed1ee8c6d83c2
+EBUILD pyldap-2.4.37.ebuild 2337 BLAKE2B f72cdcae117c80a6dd819004bbd4dd363a2600e6005d23a696837d44f72aa429a475ea649a940e2bc8a918195b47dbc922b0e187b74cad86d8a9dd0580229743 SHA512 ce89ee48d7ce81bac12c5263ad407c560b681189c66ff0c95543041a1da549fc68f237df9ac35018674bc1a72e00bee6c5bbb75c19a12bf1cca8a68eb5cc9b26
+MISC metadata.xml 529 BLAKE2B 728228ca81c7f5cadb6d98316d4bfbfacdbc4dd85c452d458fa7a939562c9739f3db02c676b09851b97fdb415a0d5273986d1a518c76edef5ab14a6c1fce0694 SHA512 47560d8da0a2c956d1004cb8dff9371937980c013ccb23038faeb421d859b6fa943cd17c751a277afe6df22b8342550b06a4504a52bfc4b24881d7fa05eedb99
diff --git a/dev-python/pyldap/metadata.xml b/dev-python/pyldap/metadata.xml
new file mode 100644
index 000000000000..6879e4d2de95
--- /dev/null
+++ b/dev-python/pyldap/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ <description>Upstream of the python3 port</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-ldap</remote-id>
+ <remote-id type="github">pyldap/pyldap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyldap/pyldap-2.4.37.ebuild b/dev-python/pyldap/pyldap-2.4.37.ebuild
new file mode 100644
index 000000000000..477edd8cec1c
--- /dev/null
+++ b/dev-python/pyldap/pyldap-2.4.37.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1 multilib
+
+DESCRIPTION="Various LDAP-related Python modules"
+HOMEPAGE="https://pypi.org/project/pyldap/ https://github.com/pyldap/pyldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-solaris"
+IUSE="doc examples sasl ssl"
+
+# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
+# python team: Please do not remove python-ldap-2.3.9 from the tree.
+# OpenSSL is an optional runtime dep.
+# setup.py sets setuptools and misses pyasn1 and pyasn1-modules in install_requires
+RDEPEND="
+ >net-nds/openldap-2.4.11
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND+=" !dev-python/python-ldap"
+
+python_prepare_all() {
+ sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
+ -e "s:^include_dirs =.*:include_dirs = ${EPREFIX}/usr/include ${EPREFIX}/usr/include/sasl:" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs="ldap"
+ if use sasl; then
+ use ssl && mylibs="ldap_r"
+ mylibs="${mylibs} sasl2"
+ else
+ sed -e 's/HAVE_SASL//g' -i setup.cfg || die
+ fi
+ use ssl && mylibs="${mylibs} ssl crypto"
+ use elibc_glibc && mylibs="${mylibs} resolv"
+
+ sed -e "s:^libs = .*:libs = lber ${mylibs}:" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+
+ # set test expected to fail to expectedFailure
+ sed -e "s:^ def test_bad_urls: @unittest.expectedFailure\n def test_bad_urls:" \
+ -i Tests/t_ldapurl.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C Doc html
+}
+
+python_test() {
+ # XXX: the tests supposedly can start local slapd
+ # but it requires some manual config, it seems.
+
+ "${PYTHON}" Tests/t_ldapurl.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/.build/html/. )
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r Demo
+ docompress -x /usr/share/doc/${PF}/Demo
+ fi
+}