summaryrefslogtreecommitdiff
path: root/dev-python/pyinsane/pyinsane-2.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyinsane/pyinsane-2.0.12.ebuild')
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyinsane/pyinsane-2.0.12.ebuild b/dev-python/pyinsane/pyinsane-2.0.12.ebuild
new file mode 100644
index 000000000000..49ee194e7e56
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/openpaperwork/pyinsane"
+SRC_URI="https://github.com/openpaperwork/pyinsane/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+
+ # Upstream Makefile requires git checkout
+ echo "version = \"${PV}\"" > pyinsane2/_version.py || die
+}