summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyicu/pyicu-2.6.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.6.ebuild b/dev-python/pyicu/pyicu-2.6.ebuild
new file mode 100644
index 000000000000..8b50556d8dcd
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN=PyICU
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest