summaryrefslogtreecommitdiff
path: root/dev-python/pygtk/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygtk/files')
-rw-r--r--dev-python/pygtk/files/pygtk-2.13.0-fix-codegen-location.patch11
-rw-r--r--dev-python/pygtk/files/pygtk-2.14.1-libdir-pc.patch12
-rw-r--r--dev-python/pygtk/files/pygtk-2.24.0-fix-leaks.patch58
-rw-r--r--dev-python/pygtk/files/pygtk-2.24.0-quartz-objc.patch45
-rw-r--r--dev-python/pygtk/files/pygtk-2.24.0-test-fail.patch9
-rw-r--r--dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch28
6 files changed, 0 insertions, 163 deletions
diff --git a/dev-python/pygtk/files/pygtk-2.13.0-fix-codegen-location.patch b/dev-python/pygtk/files/pygtk-2.13.0-fix-codegen-location.patch
deleted file mode 100644
index 701d828f1f88..000000000000
--- a/dev-python/pygtk/files/pygtk-2.13.0-fix-codegen-location.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/pygtk-2.0.pc.in 2007-11-01 12:20:22.000000000 -0400
-+++ b/pygtk-2.0.pc.in 2008-05-28 22:21:04.000000000 -0400
-@@ -12,7 +12,7 @@ pygtkincludedir=${includedir}/pygtk-2.0
- # This is strictly speaking not necessarily so (we refer to another
- # package), but we want to preserve compatibility with times codegen
- # was in PyGTK, not PyGObject.
--codegendir=${datadir}/pygobject/2.0/codegen
-+codegendir=${pyexecdir}/gtk-2.0/codegen
-
- Name: PyGTK
- Description: Python bindings for GTK+ and related libraries
diff --git a/dev-python/pygtk/files/pygtk-2.14.1-libdir-pc.patch b/dev-python/pygtk/files/pygtk-2.14.1-libdir-pc.patch
deleted file mode 100644
index d943e952a421..000000000000
--- a/dev-python/pygtk/files/pygtk-2.14.1-libdir-pc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-https://bugzilla.gnome.org/show_bug.cgi?id=663421
-
---- a/pygtk-2.0.pc.in
-+++ b/pygtk-2.0.pc.in
-@@ -12,6 +12,7 @@
- includedir=@includedir@
- datarootdir=@datarootdir@
- datadir=@datadir@
-+libdir=@libdir@
- pyexecdir=@pyexecdir@
-
- # you can use the --variable=pygtkincludedir argument to
diff --git a/dev-python/pygtk/files/pygtk-2.24.0-fix-leaks.patch b/dev-python/pygtk/files/pygtk-2.24.0-fix-leaks.patch
deleted file mode 100644
index 9106d43c4192..000000000000
--- a/dev-python/pygtk/files/pygtk-2.24.0-fix-leaks.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From eca72baa5616fbe4dbebea43c7e5940847dc5ab8 Mon Sep 17 00:00:00 2001
-From: Owen W. Taylor <otaylor@fishsoup.net>
-Date: Tue, 27 Sep 2011 04:17:52 +0000
-Subject: Fix leaks of Pango objects
-
-Gtk.PrintContext.create_pango_context()
-Gtk.PrintContext.create_pango_layout()
-pangocairo.CairoContext.create_layout()
-
-were leaking the objects they returned.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=660216
----
-diff --git a/gtk/gtk-2.10.defs b/gtk/gtk-2.10.defs
-index 69c7e0c..faa45e1 100644
---- a/gtk/gtk-2.10.defs
-+++ b/gtk/gtk-2.10.defs
-@@ -1388,12 +1388,14 @@
- (define-method create_pango_context
- (of-object "GtkPrintContext")
- (c-name "gtk_print_context_create_pango_context")
-+ (caller-owns-return #t)
- (return-type "PangoContext*")
- )
-
- (define-method create_pango_layout
- (of-object "GtkPrintContext")
- (c-name "gtk_print_context_create_pango_layout")
-+ (caller-owns-return #t)
- (return-type "PangoLayout*")
- )
-
-diff --git a/pangocairo.override b/pangocairo.override
-index bb923e6..5101107 100644
---- a/pangocairo.override
-+++ b/pangocairo.override
-@@ -118,11 +118,16 @@ _wrap_pango_cairo_update_context(PyGObject *self, PyObject *args, PyObject *kwar
- static PyObject *
- _wrap_pango_cairo_create_layout(PyGObject *self)
- {
-- PangoLayout *ret;
-+ PangoLayout *layout;
-+ PyObject *ret;
-
-- ret = pango_cairo_create_layout(PycairoContext_GET(self));
-+ layout = pango_cairo_create_layout(PycairoContext_GET(self));
- /* pygobject_new handles NULL checking */
-- return pygobject_new((GObject *)ret);
-+ ret = pygobject_new((GObject *)layout);
-+ if (layout)
-+ g_object_unref(layout);
-+
-+ return ret;
- }
-
- static PyObject *
---
-cgit v0.9.2
diff --git a/dev-python/pygtk/files/pygtk-2.24.0-quartz-objc.patch b/dev-python/pygtk/files/pygtk-2.24.0-quartz-objc.patch
deleted file mode 100644
index 828057e62b73..000000000000
--- a/dev-python/pygtk/files/pygtk-2.24.0-quartz-objc.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From: Anders F Bjorklund <afb@users.sourceforge.net>
-Date: Mon, 4 Apr 2011 21:34:20 +0200
-Subject: [PATCH] use objective-c for quartz
-
-https://bugzilla.gnome.org/show_bug.cgi?id=646743
----
- configure.ac | 5 +++++
- gtk/Makefile.am | 5 +++++
- 2 files changed, 10 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 84c78f6c..27192f9c 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -445,6 +445,11 @@ case $gdk_target in
- ;;
- esac
-
-+if test "x$gdk_target" = "xquartz"; then
-+ AM_CONDITIONAL(USE_QUARTZ, true)
-+else
-+ AM_CONDITIONAL(USE_QUARTZ, false)
-+fi
-
- dnl checks to see if numpy is installed.
- AC_ARG_ENABLE(numpy,
-diff --git a/gtk/Makefile.am b/gtk/Makefile.am
-index 7bb5d0c8..44d68700 100644
---- a/gtk/Makefile.am
-+++ b/gtk/Makefile.am
-@@ -9,6 +9,11 @@ INCLUDES = \
- $(PYGOBJECT_CFLAGS) \
- -I$(srcdir)/gtk
-
-+if USE_QUARTZ
-+# same as in gtk+/gdk/quartz/Makefile.am
-+INCLUDES += "-xobjective-c"
-+endif
-+
- # defs files
- defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
- defs_DATA =
---
-2.12.0
-
diff --git a/dev-python/pygtk/files/pygtk-2.24.0-test-fail.patch b/dev-python/pygtk/files/pygtk-2.24.0-test-fail.patch
deleted file mode 100644
index 5bb1aec13d89..000000000000
--- a/dev-python/pygtk/files/pygtk-2.24.0-test-fail.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- tests/runtests.py
-+++ tests/runtests.py
-@@ -41,4 +41,5 @@
- suite.addTest(loader.loadTestsFromName(name))
-
- testRunner = unittest.TextTestRunner()
--testRunner.run(suite)
-+result = testRunner.run(suite)
-+sys.exit(not result.wasSuccessful())
diff --git a/dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch b/dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch
deleted file mode 100644
index 832007af2328..000000000000
--- a/dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From eb92ecdfe7e310499743a5686560e18bb48ef0f0 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Wed, 2 Oct 2013 14:51:20 -0400
-Subject: [PATCH] tests: fix MessageDialogTest.testSubclass
-
-Don't check sub.__gtype__ until we set sub
-
-https://bugzilla.gnome.org/show_bug.cgi?id=709304
----
- tests/test_dialog.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_dialog.py b/tests/test_dialog.py
-index a6a3ce5..6540be3 100644
---- a/tests/test_dialog.py
-+++ b/tests/test_dialog.py
-@@ -20,7 +20,7 @@ class MessageDialogTest(unittest.TestCase):
- print sub.__gtype__.name
- self.assertEqual(sub.__gtype__.name, 'GtkMessageDialog')
-
-- type('Sub', (gtk.MessageDialog,), {'__gtype_name__': 'SubDialog'})
-+ sub = type('Sub', (gtk.MessageDialog,), {'__gtype_name__': 'SubDialog'})
- self.assertEqual(sub.__gtype__.name, 'SubDialog')
-
- def testDialogLeak(self):
---
-1.8.3.2
-