summaryrefslogtreecommitdiff
path: root/dev-python/pygresql
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest2
-rw-r--r--dev-python/pygresql/pygresql-6.0.1.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index 08d8706993bb..3fc143602530 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1,4 +1,6 @@
AUX pygresql-5.2-CFLAGS.patch 333 BLAKE2B caa18ab6ba4da14437637faf6cea4d27e829c4f547f9c08e33a452b1e5912a24235af823c9ea385bbd1516c0c80a08d3225e373ad64ad4d13873ff4dc5155695 SHA512 ddafaadb4ebfb68af71727f840f36800d3dd78323f8ab0324a16b50498206c8ac33c76a80f24fff7984195ed5ac0fc383bdcacb9ea334f4b47e5046864728cd0
DIST PyGreSQL-6.0.tar.gz 271585 BLAKE2B 80e5dc9be955ac2b9a69b1cdbc6f164d11bd8f0386da340fc414340a7ebc7e857727f8b6570acf6696ac83daeb41ef80cc5875f4ae0ea766e838d54d96b33910 SHA512 a6ed1f252a40ae4c429c142cc408993bfe5ec7a4318cf219f977a440a3e3f823291b160843bc497e3375e5acc36b8043178f77c0f9cfd108e580e80b7a5c8eb9
+DIST pygresql-6.0.1.tar.gz 271855 BLAKE2B 76d3f18d2bdbe7aa1d4459784fd5f1d3d76feaaeb911f1679c66d1a579cef27a00af619416f03cfcd69804e4f5a997d82765c3e32d9ab371c6011b0915e3e018 SHA512 47b0296596d5d914ccd48e09f352f8da38ed82a0861a148525a675431df51b1261d03e7bbb158947d4d525d82e1790d0a4d4c4d293b29550c50965e2a4e89847
+EBUILD pygresql-6.0.1.ebuild 1393 BLAKE2B a249c881b88aa47ef9f1b574ca1e872d7c4584d62f8471bfff8b333b92d3b2d229060a7de13a4ad6bd7118caf7640e901cfde8f08d4490c1833d627f5bcf67bc SHA512 7368a79d5332d88de5621f4be2306a652a6d9a17259b532b7be04d09b61be00cc7a22ff84f1a1c23d3f7ae08ef8d213d4a0abcc68df0dc2d07f23d46309e9565
EBUILD pygresql-6.0.ebuild 1410 BLAKE2B 754bcb2d09243228e4f7fa0019b117ee9cb25a0367f100fe246d6d93fd9697c5e6295f7ca634dc71567a9218dcf7658954c25a5cde405cecca8068f1ba602fd9 SHA512 c91a5ae59bfddf6ecec5f54b8d21f516b706dc03b321ccac503fdf6f3c59ca9a247c47604c511bb93ebb750f160c6c8c6b392915563228026f4575eaec02d361
MISC metadata.xml 510 BLAKE2B cde75458658f9434322620377e1f5b99c9a0aa484e164ab5dcdbee94e4beebe646ff052783984c95245791bb4006545037768928a6e2664e1bb72df5aea49ae7 SHA512 e5750c6fc17dc5368142847318bf1842a17e2f46ac1ef01aa4658ec1c51705c5f160e75018567f83f41b0b4fd226ef019779f406513cc2d5b9e68bf420b51b81
diff --git a/dev-python/pygresql/pygresql-6.0.1.ebuild b/dev-python/pygresql/pygresql-6.0.1.ebuild
new file mode 100644
index 000000000000..6c126fb8b7d0
--- /dev/null
+++ b/dev-python/pygresql/pygresql-6.0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="PyGreSQL"
+POSTGRES_COMPAT=( 9.6 {10..16} )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 postgres pypi
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="
+ https://pygresql.github.io/
+ https://github.com/PyGreSQL/PyGreSQL/
+ https://pypi.org/project/PyGreSQL/
+"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-db/postgresql[server]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ postgres_pkg_setup
+ fi
+}
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage test || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ rm -rf pg || die
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}