summaryrefslogtreecommitdiff
path: root/dev-python/pygresql/pygresql-5.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygresql/pygresql-5.0.4.ebuild')
-rw-r--r--dev-python/pygresql/pygresql-5.0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pygresql/pygresql-5.0.4.ebuild b/dev-python/pygresql/pygresql-5.0.4.ebuild
new file mode 100644
index 000000000000..02d9d5b7bc8d
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} 10 )
+PYTHON_COMPAT=( python2_7 python3_{4..6} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86"
+IUSE=""
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+DEPEND="${POSTGRES_DEP}"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}