summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz/pygraphviz-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.5.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.5.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.5.ebuild b/dev-python/pygraphviz/pygraphviz-1.5.ebuild
deleted file mode 100644
index d87dcfbc259a..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="https://pygraphviz.github.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
-RDEPEND="media-gfx/graphviz"
-DEPEND="${RDEPEND}
- dev-lang/swig:0
- test? (
- dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-docs.patch
-)
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- swig -python pygraphviz/graphviz.i || die
-}
-
-python_test() {
- PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
- nosetests -c setup.cfg -x -v || die
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}