summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz/pygraphviz-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.2.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.2.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.2.ebuild b/dev-python/pygraphviz/pygraphviz-1.2.ebuild
deleted file mode 100644
index c4a7bc3f7843..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ https://pypi.org/project/pygraphviz/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
-
-# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
-RDEPEND="media-gfx/graphviz"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0-setup.py.patch
- "${FILESDIR}"/${P}-avoid_tests.patch
-)
-
-python_test() {
- PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
- "${PYTHON}" \
- -c "import pygraphviz.tests; pygraphviz.tests.run()" \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}