summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest2
-rw-r--r--dev-python/pygments/pygments-2.8.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 48c08ff03541..29e595943bb1 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,5 @@
DIST Pygments-2.7.4.tar.gz 2325473 BLAKE2B 48e45f8d58e4d06be71cacbfbcbee57c69fe0b4c344c1dde2054912f1b74c67db19c24de2661acab7026ea78420ff90e4596e1a89b783ce79ebea12c8d3a7a60 SHA512 84fb2e0c52e4683d52524ee1d70c11a9ff6cc0b21fe6aa3e1a6c4fac393f87267756b1c04b7c2555799e387b2e9ca7d2e7703ddc1690a642aa263ed27510e030
+DIST Pygments-2.8.0.tar.gz 3999484 BLAKE2B 5267a4a9e18a01897906239d2cb4f508675e0de3d9a33ae9b144424b18883da53937d92755f8ab1ddc7b10a248031fb693b4012407079aca1d08c8924360e75d SHA512 7e3dd2119769b704d6bbd4867c85eedb0d3c8ac415280fb35a1194284511c6fe6c5696bf6515e14da7a944b7ad5aeb945a71e79abcd1a42949ca30bbfe2e31b3
EBUILD pygments-2.7.4.ebuild 1234 BLAKE2B 1abc07b72f10c8bbc95dc597052682911eed7fbf49b3e9f37fec207cd602c3c4837200c84eaf00abccbfeba93641caa1ff033379902f69a04479c17cf72856f7 SHA512 cbe478ba3832cf4a28fac676e2608e7758052e4a166316a77fd26a69eb20995b4d04939271ad40c54bd58d26c423667e6609fbee45dff4bc5c24a961efa13b5c
+EBUILD pygments-2.8.0.ebuild 1248 BLAKE2B a13c017b5279c248b9cda129f413d7f725955417fccf38a4a0ad3877cc13fecaa9f90381037139339af83777dfd01c0e5eff9e3621b45afa487621a486b18042 SHA512 5ddb26823783fda50bb0c97626cafae831ed16977666b88e093ebfc464d8919f5c689b64f40e9e15eefda9e3b8aa56b240ceebb3686228fcee88598d2164e7be
MISC metadata.xml 556 BLAKE2B 87120b6aafeefb97b45a6895b23d08c6443cb177d5bc337845bec55ebdb59ee9eb19ef41c10b3ce4d61452c602f925b4120a441959b5b5d5fea26e15de4a1510 SHA512 b5f4491bb714e2abef07da4e960609aae651ceae3153102467e19bc4d06b9006418729f0b915cc026842253287786faa083d608c0ad5bd7f5c423922740580bd
diff --git a/dev-python/pygments/pygments-2.8.0.ebuild b/dev-python/pygments/pygments-2.8.0.ebuild
new file mode 100644
index 000000000000..eb9fa4c20022
--- /dev/null
+++ b/dev-python/pygments/pygments-2.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ # there is a known bug in regex engine of pypy3.7
+ [[ ${EPYTHON} == pypy3 && $(pypy3 --version) == "Python 3.7"* ]] &&
+ deselect+=( tests/snippets/crystal/test_macro.txt:: )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}