summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest2
-rw-r--r--dev-python/pygments/pygments-2.3.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index efc4fb506694..c460f71d859d 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,6 +1,8 @@
AUX pygments-2.2.0-pep479.patch 1669 BLAKE2B c39e582d85d5903831749ccf563b13a88f623ebe7279205465bba16640fb85df1d1f9d15020d7e19b9d0ca8fb409426dbcfec4729e8d1b16d90e9c075f674c25 SHA512 e6195c6f0c0fb0ba725621ad564e85e69db31a3e2e903279512d0af06db32d7fee1284ddd0db00c80312c29a19f345325a7353bc5fc2e1f0bc64f8c32f71d918
AUX pygments-2.2.0-sphinx17.patch 645 BLAKE2B 07601a0e952d6e5f978d111a273bfe8c6fa6489e23acad4f61beb535e37aff1e3182a5317ab4e424a1b632924bb3c1b3562aefda17b638aa5a367d861f164c64 SHA512 937ce1168ab488387918220995f1f32e4664a505af3b6610143af15b6cfd3bab1d1fa4a0dc54c59db2ce0775edcc762f70ff948f8bd4e3bbeceb14774d30f287
DIST Pygments-2.2.0.tar.gz 2113944 BLAKE2B 58d5f2fa0e6d97f5b7d7a17314b82ef219f23b72f8da49b4f8ce9b892d54ffbc1b490e87e87efe8d727dab297f775d0d8abfc4a31a734c5a7f8df885e5eda82f SHA512 cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29
+DIST Pygments-2.3.1.tar.gz 3124216 BLAKE2B 99a5f96a2d2f9deb1a6b6ad94a21ab7f517cde47b1e91b67ce594732004cf99db51b1240e0270473f87f5d8a435172545b9fa3449a2ddc113faf5aaef6c34f73 SHA512 2c36cb42f8dd62e04b7664b5e87f951a8428ccbb6dbe5b5b43d8c7e6923ada0ab55a231bb8e9ed79eb5a85344ed64d3acc8e7bc991ab1f49c58eb612b8002c1e
EBUILD pygments-2.2.0-r1.ebuild 1619 BLAKE2B 0ce67e1c2184243e27e0af9500334a8bbc672a5820d1095c45a18759009c39611de47900787455889e70bedc2d77aff36d75ea0f27ec9680559c3c004c8f0e74 SHA512 eed66e18d882fdb5ee5120d825e4dea785bd1bdcdce6da2b9a4c6031366bc5279c37cb882337f0c1a8ea7cb7bc8f1813f8ad62baba14b3694061d5c59d3ed401
EBUILD pygments-2.2.0.ebuild 1773 BLAKE2B 4994e4e0f2e0f98e2900ce3d2e39f9b14f82d1b357fa4a530f59ffc4b73d744288d3d7a55cacbfb58248f5fe754d0840b0bc82c2ab6138bfa540c78383cbca6a SHA512 58ed43530ae8ce8da04a04a7d38a09b1ec43fb0237eef446a6050ab480a584ae0c4805fab8dbe24694469372426358c434941117a0eed33d49e773b306161e5d
+EBUILD pygments-2.3.1.ebuild 1437 BLAKE2B 0841c758f4df7614e7ac616bb490bc953444098957a347da7cfd5d99717ef1fe33a2f2112ccfca7666ee2e67f3ccc1850e47b76cc2e1e307582385149cdc7913 SHA512 0ecc078426fc5f24a2302239e23fea8c9ef2a1dc66317717cd7204ef5f1634c0e32f816f08605577c4fdf9ba6c1272e89d85380b5a105997ae414b13cf1cc573
MISC metadata.xml 542 BLAKE2B 88e44c4b6f29e096e67521c621724d1a5415d089f73612fb8d02ee714a4af1e8080cf98542d7f0c9b1331d919bbeba31b1fa8269a28cc1be841af069a497d889 SHA512 f15732bb743ed5ad4049036c7b87118c89be09e260ae483b4c7e25155a31c0ab8844f8a1050386a0ee81d2b1e55d240f90cab3e28749b8f943baf64ec176814b
diff --git a/dev-python/pygments/pygments-2.3.1.ebuild b/dev-python/pygments/pygments-2.3.1.ebuild
new file mode 100644
index 000000000000..7d246ca5ef77
--- /dev/null
+++ b/dev-python/pygments/pygments-2.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="http://pygments.org/ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+ # With pypy3 there is 1 error out of 1556 tests when run as is and
+ # (SKIP=8, errors=1, failures=1) when run with 2to3; meh
+ nosetests --verbosity=3 -w "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}