summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-1.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygit2/pygit2-1.14.0.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-1.14.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pygit2/pygit2-1.14.0.ebuild b/dev-python/pygit2/pygit2-1.14.0.ebuild
deleted file mode 100644
index afac9dd7571b..000000000000
--- a/dev-python/pygit2/pygit2-1.14.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="
- https://github.com/libgit2/pygit2/
- https://pypi.org/project/pygit2/
-"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-DEPEND="
- =dev-libs/libgit2-1.7*:=
-"
-BDEPEND="
- >=dev-python/cffi-1.16.0:=[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
- ${BDEPEND}
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unconditionally prevent it from using network
- sed -i -e '/has_network/s:True:False:' test/utils.py || die
-}
-
-src_test() {
- rm -r pygit2 || die
- distutils-r1_src_test
-}