summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-0.27.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygit2/pygit2-0.27.4.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.27.4.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pygit2/pygit2-0.27.4.ebuild b/dev-python/pygit2/pygit2-0.27.4.ebuild
deleted file mode 100644
index 79087595fdfa..000000000000
--- a/dev-python/pygit2/pygit2-0.27.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-inherit distutils-r1 eapi7-ver
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- =dev-libs/libgit2-$(ver_cut 1-2)*
- >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
- sed -i -e '/pycparser/s:<2.18::' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv --import-mode=append test || die
-}