summaryrefslogtreecommitdiff
path: root/dev-python/pyghmi/pyghmi-1.5.69.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyghmi/pyghmi-1.5.69.ebuild')
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.69.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyghmi/pyghmi-1.5.69.ebuild b/dev-python/pyghmi/pyghmi-1.5.69.ebuild
new file mode 100644
index 000000000000..f4adcb0eed3b
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.69.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest