summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest4
-rw-r--r--dev-python/pyftpdlib/metadata.xml1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild22
3 files changed, 12 insertions, 15 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 855d86d77585..ba3792d8d99d 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1,3 @@
DIST pyftpdlib-1.5.6.tar.gz 188099 BLAKE2B 508e94da6b27b4b1f15306df2916c176f07ca31944398e9ac580fca8d2cdc72ca0ee8e7db282de6745e2e401b23b1fa8cb8de400dc2ba998b93ac45772c78157 SHA512 a3c3c1cac221a8a3c090ee208c03134bb1b8de58099a23ca6ee422f06fb97a0ed561c96e62c62b21fa112dd0b3458651b9fc0c55d72dc0bed79d0583b319a50d
-EBUILD pyftpdlib-1.5.6-r1.ebuild 3566 BLAKE2B d9fca8a7c37471dab8a7a8f08bf9fbd2b3998088b32beb8230a76aa11340c7a41addbcfeebaeee0f47892e254d37b254f151d8b8da2bc03413fd7bcf95ba37a1 SHA512 566835db092e438071d2ea2fb5b86cf7405838bebbb8fccee1a0f00c9b105eb8fb753912e035e7fac6fcf6502badbf24a825326c70ccb0617ef96eb0447d10c6
-MISC metadata.xml 438 BLAKE2B 0e0860eb9d885ec9b432b504bef6a9394cf4a2d6d99751c80fec8441d8910f8a17364e5f32782638ac689abf5cdd3ebcb5fa20e7da3d612a5e8844e8c8a34d76 SHA512 a748827370b53c94fed352cd6bbd7468a22c7ca2f15c4601c98a2689e3a7e652ed28434bcd125fe0f3018d5508600df03130c18d7d67834b28ac0c3480b16345
+EBUILD pyftpdlib-1.5.6-r1.ebuild 3213 BLAKE2B 20d7442ad487c0e984bdf11a1d2b2bb6868f0efdde16fe642acb50521edb3219526c94dcfbbdf504320bdbf2c2c3ceb073da26e8336bdc9002e0333127350fef SHA512 ac354e86f64ba305b48e63f9285550c15e5f7776eff612c6590c8c0e70e52a184bf30d89928249512496e5be847915bb2efac275ea3ca509dcd4a810962f86b9
+MISC metadata.xml 462 BLAKE2B 0eff8a15eb9d31aad088c5467521593e2b8249243067d173c58fcbc39f184b47e17b256f5243c34b58aac6ff5c82aa3ff7a712750158e2fab03a610dff7204e4 SHA512 c9aef28b42efb6cf397fab4ba0061f7e0abade98d7612209dc97a2e9dbb810153801c49726e6bade138d73ad04ee6c19b48f2a6006a0cdbc59db1cd1de7e3be5
diff --git a/dev-python/pyftpdlib/metadata.xml b/dev-python/pyftpdlib/metadata.xml
index 1a0a7b81d04c..f2383d4b66ac 100644
--- a/dev-python/pyftpdlib/metadata.xml
+++ b/dev-python/pyftpdlib/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyftpdlib</remote-id>
<remote-id type="github">giampaolo/pyftpdlib</remote-id>
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index a063b7e0f3b6..f6e04c744b72 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -15,24 +15,24 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="examples ssl test"
-RESTRICT="!test? ( test )"
+IUSE="examples ssl"
RDEPEND="
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
"
BDEPEND="
test? (
- ${RDEPEND}
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
python_test() {
+ cd "${BUILD_DIR}"/lib || die
+
# These tests fail when passing additional options to pytest
# so we need to run them separately and not pass any args to pytest
pytest ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
@@ -40,16 +40,9 @@ python_test() {
local skipped_tests=(
# Those tests are run separately
pyftpdlib/test/test_misc.py
- # https://github.com/giampaolo/pyftpdlib/issues/470
- # https://bugs.gentoo.org/659108
- pyftpdlib/test/test_functional_ssl.py::TestTimeouts::test_idle_data_timeout2
- pyftpdlib/test/test_functional_ssl.py::TestTimeoutsTLSMixin::test_idle_data_timeout2
# https://github.com/giampaolo/pyftpdlib/issues/471
# https://bugs.gentoo.org/636410
pyftpdlib/test/test_functional.py::TestCallbacks::test_on_incomplete_file_received
- # https://github.com/giampaolo/pyftpdlib/issues/466
- # https://bugs.gentoo.org/659786
- pyftpdlib/test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
# https://github.com/giampaolo/pyftpdlib/issues/512
# https://bugs.gentoo.org/701146
pyftpdlib/test/test_functional_ssl.py::TestFtpStoreDataTLSMixin::test_rest_on_stor
@@ -74,7 +67,10 @@ python_test() {
pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address_map
)
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- TZ=UTC+1 epytest ${skipped_tests[@]/#/--deselect }
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ epytest -p no:xvfb ${skipped_tests[@]/#/--deselect }
}
python_install_all() {