summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild')
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
index 14ef11ae7fec..a956577edbe4 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+KEYWORDS="~amd64 ~arm ~hppa ia64 ~m68k ~mips ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="doc examples ssl test"
RDEPEND="
@@ -48,15 +48,24 @@ python_compile_all() {
}
python_test() {
- # Skip tests which sometimes fail:
- # https://github.com/giampaolo/pyftpdlib/issues/470
- # https://github.com/giampaolo/pyftpdlib/issues/471
- py.test --ignore ${PN}/test/test_misc.py -k \
- "not (test_idle_data_timeout2 or test_on_incomplete_file_received)" \
- || die "Tests failed with ${EPYTHON}"
# These tests fail when passing additional options to py.test
# so we need to run them separately
py.test ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
+ # Some of these tests tend to fail
+ local skipped_tests=(
+ # https://github.com/giampaolo/pyftpdlib/issues/470
+ # https://bugs.gentoo.org/659108
+ test_idle_data_timeout2
+ # https://github.com/giampaolo/pyftpdlib/issues/471
+ # https://bugs.gentoo.org/636410
+ test_on_incomplete_file_received
+ # https://github.com/giampaolo/pyftpdlib/issues/466
+ # https://bugs.gentoo.org/659786
+ test_nlst
+ )
+ skipped_tests=${skipped_tests[@]/%/ or}
+ py.test --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
+ || die "Tests failed with ${EPYTHON}"
}
python_install_all() {