summaryrefslogtreecommitdiff
path: root/dev-python/pyfire/pyfire-0.3.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyfire/pyfire-0.3.4-r2.ebuild')
-rw-r--r--dev-python/pyfire/pyfire-0.3.4-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyfire/pyfire-0.3.4-r2.ebuild b/dev-python/pyfire/pyfire-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..be8374a0c348
--- /dev/null
+++ b/dev-python/pyfire/pyfire-0.3.4-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A python implementation of the Campfire API"
+HOMEPAGE="https://github.com/mariano/pyfire"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"