summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest2
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.5.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 3f22058c67d9..a347bdf231e9 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,5 @@
DIST pyfakefs-5.4.1.gh.tar.gz 237928 BLAKE2B 8abea2d884d69717ab754c38666633f86230e981ddb099f8f9493d4d82ff0ff73e644ec793ea5e68edc662fee72dfd833fcab068b73fd5285555d2e5d8445823 SHA512 f27ce662a443623717a91e3fe1895cbbf7a64d009b7846b61c890ebabb0c3bb978b12bb83b68460fc026f4a0cfe846afb6057b72306e822dc8ba75d6e2f1b555
+DIST pyfakefs-5.5.0.gh.tar.gz 239883 BLAKE2B cf9b91fbfbb77b012ec768ac2188ea5c611a271f50ded69cc92607d955b4dda8cacf7b0560da5a2b57f7a4aa6879fafb328357e5996d8c7c025f531530a04f4d SHA512 d9f05318f26ca9c26e0cca3c4fdf19dc3cf33bd21a6a87e1e4d8871b06eba9d8ba875301b001221ec9e0bd17c14f8aba3e61d3ec5b3c72587d28b7b5263e2a2c
EBUILD pyfakefs-5.4.1.ebuild 1122 BLAKE2B 6aed8c356657877632fe1d9c425458374d37a8ed2e008b658b2376129a5e1bc0064da687d693abb13a68737b99dd35aeb677f77adc30520a6b1dc54993d93214 SHA512 b667dbb8c0e49e56532e3abf90133aec043e64e29db73d772c5e33b0c15981d93abfd7581bd327f4bb3f19d9ed3633d2428d1ccbe9ef58e097e2c506e4286d92
+EBUILD pyfakefs-5.5.0.ebuild 1130 BLAKE2B 89db069a1d24a89e080d1d466f7cd3820c9198f39ef456b7d13ae1e3e29f146087fcaa01297325a3d2061df75f462286af9bb407c2148ea2090f8505afa1276a SHA512 1424b9759629fff4846193c889f85d25f114c8dff2cbe4515e00bbbe87afd06be3bde4d76a3e5224c258e0d79a005ba33ef0bdbb9bcaef82bece529a02192be5
MISC metadata.xml 395 BLAKE2B add696dab9f93cad522087325d7cea08bb0d6905a093c0dd721b8ee0cc5f06a97e8b29663920e5131fd1cfaf38a1fb1c22908daa155025713ffbf18d87a2d5ec SHA512 454f9cf42ae315bb9d4b7c9a2a8b9a690163befc8f738b1fe4a145f1f3a9a5f59693e4cd1ebd4c501005cac1ab81c8b57b2316ac50739dfa96919b6de4850b9a
diff --git a/dev-python/pyfakefs/pyfakefs-5.5.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.5.0.ebuild
new file mode 100644
index 000000000000..85eb97cbee97
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ # test for regression with undefined package
+ pyfakefs/pytest_tests/pytest_fixture_test.py
+ )
+
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ pyfakefs/pytest_tests/pytest_reload_pandas_test.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}