summaryrefslogtreecommitdiff
path: root/dev-python/pydot
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/Manifest2
-rw-r--r--dev-python/pydot/pydot-3.0.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
index 4200973202ec..235b9e5fbb10 100644
--- a/dev-python/pydot/Manifest
+++ b/dev-python/pydot/Manifest
@@ -1,5 +1,7 @@
DIST pydot-2.0.0.gh.tar.gz 275188 BLAKE2B 58f1598196861795bd44c6b97683e0c37b3c05e848a69d42a3fc898849f272466c989e7ff72e0be22a322a1e92c31c6b76a9317e56f3ec26743c20801daf8bfd SHA512 09102930a59ac4339e1d1e4f7a9d075f99eda6cb060885631a72f1fded90d001bd02940b55addc0c92856e95321cb3b344a1797b4809ac7c9048ac57c81d4707
DIST pydot-3.0.0.gh.tar.gz 280655 BLAKE2B 0c58f5a03cdb2eb325aec96e532bbe4808170a3828377ba3a278c8c5631de9c74716a19426ebb0834ecba063b92c31ef41965edb1ee22018ed658e0e4e17bc7a SHA512 493601a54e9727d727b1ff3fa9133da400dd02ca147f04b5c446a2baeda3b5ae60d0edccaf122e946abe984f7d9e375cda553a22608b070e06e8f59eda82d565
+DIST pydot-3.0.1.gh.tar.gz 280784 BLAKE2B d87d06bf5f62ae783ecb4ff6a16b0986969de49cbf45e120df5e722620fe614181700f8117b0a6ce24fd4aac4f618d4dc16c631f581ebb19bea73a5a92437585 SHA512 6aca6e91134e481334c12a7669d3f5df1181f9a4e2ab914a6c8ab87f28d0afa9d97cfc0d9b665d9fdedb3c335624d68967d491f79fc669573aa81cf1401316cd
EBUILD pydot-2.0.0.ebuild 970 BLAKE2B 05495c7bc98615ddaad934411c481474469ba23cc174b880490e60e7dfded9b92a2d360f7355f27b286d52b55de6d44336df9388e1050d0bf97d8b103c0a649c SHA512 4652347414632080f30f05ae3dbf5a272ab9286c76610a63c94b2d364f11c5edf142038f9af6442156c7ba18856b47950e835c371b53e03ba3812cddb1408fa5
EBUILD pydot-3.0.0.ebuild 872 BLAKE2B 6368693e19685b3ccda009f3fedbb0590e5507051ac82d2b8982062c82dabeff05b3ef652fff7c743430a1d6c93998916c791306498acb8dc4b3dcc5c69dc4f0 SHA512 3483b54673ba51064c4d0b8a4de645376e1c90102cfdd46953d8ac371fd1bda86112b111d432d9e64cc5403409ff0cf4bc4d276f865f97c16278a588e560e32f
+EBUILD pydot-3.0.1.ebuild 872 BLAKE2B 6368693e19685b3ccda009f3fedbb0590e5507051ac82d2b8982062c82dabeff05b3ef652fff7c743430a1d6c93998916c791306498acb8dc4b3dcc5c69dc4f0 SHA512 3483b54673ba51064c4d0b8a4de645376e1c90102cfdd46953d8ac371fd1bda86112b111d432d9e64cc5403409ff0cf4bc4d276f865f97c16278a588e560e32f
MISC metadata.xml 372 BLAKE2B faad24394ef27dedc8b563e505444b414fe95cb6097bd2bebe01232e68c975b77d415c2a05ec1ad19f0ce1218d1c3f057beea6deecef01b940962a287ad8ce46 SHA512 281a6e2097fcf978f7e691640e257a5f60b242570f8a5715e078363c5658b96b50d3c29ccaad448c0b2ac3dd7b898dcae457bafdb08952163de8d1af81954d75
diff --git a/dev-python/pydot/pydot-3.0.1.ebuild b/dev-python/pydot/pydot-3.0.1.ebuild
new file mode 100644
index 000000000000..ee9b63f3aaa8
--- /dev/null
+++ b/dev-python/pydot/pydot-3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="
+ https://github.com/pydot/pydot/
+ https://pypi.org/project/pydot/
+"
+# pypi releases don't include tests
+SRC_URI="
+ https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-3.0.9[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest