summaryrefslogtreecommitdiff
path: root/dev-python/pydata-sphinx-theme
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydata-sphinx-theme')
-rw-r--r--dev-python/pydata-sphinx-theme/Manifest3
-rw-r--r--dev-python/pydata-sphinx-theme/metadata.xml12
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pydata-sphinx-theme/Manifest b/dev-python/pydata-sphinx-theme/Manifest
new file mode 100644
index 000000000000..4e3705a6fa74
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/Manifest
@@ -0,0 +1,3 @@
+DIST pydata-sphinx-theme-0.4.0.tar.gz 3276611 BLAKE2B fb260de2ad40f9a3b5e524ef299a5bf2ee9fbe3f36a0b0e365b53a04702f8a5644154535cfa9f1f3c1deced5de8adbbaf5671488b467d3024b9ae3f60a6f7018 SHA512 abe4924277ec41193019e80a26ccb2ce195741fdae9defc9b500ecc2a63ab9070d1eba5a3398415641ef87ccfe8d573ce6fd10eb069e0f13f09891b5b5e2f932
+EBUILD pydata-sphinx-theme-0.4.0.ebuild 910 BLAKE2B bf12b45889b81de57ff9fcf74b46381696c0cc2dddcb89a223013ed2c7d5be1b1a01b85829b1df288020300b233a9375baca178a71db6d81eac05dd89c1e5c77 SHA512 31b263cc7e9745a5a78da76f6a0d6a9f73ae9cc1216666f6b691707ec87028142916542dcadb7edc6d017bf76fdb9c090f54870af1b1e898b13f2fd8a5f1c9b5
+MISC metadata.xml 375 BLAKE2B 393138e315b4eae4dacb9339fbb5766e9dbaa84b7482babaddc08d524fb8b9939f6622ee9c6d09b66c61ac270fcc483fac39996a12ba87ccccf7cafd4c6d36db SHA512 9a44b6b9de4d1a61d6af9256519473541d5513cef349c15178c025dee3aaaa3f6772b1be56576411a985fcd9c70029c00743d8f577be8eaec4c5a44646c9cbf6
diff --git a/dev-python/pydata-sphinx-theme/metadata.xml b/dev-python/pydata-sphinx-theme/metadata.xml
new file mode 100644
index 000000000000..d22e99d73577
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
new file mode 100644
index 000000000000..cdb917978f59
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap-based Sphinx theme from the PyData community"
+HOMEPAGE="https://github.com/pandas-dev/pydata-sphinx-theme"
+SRC_URI="https://github.com/pandas-dev/pydata-sphinx-theme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+)"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+# ModuleNotFoundError: No module named 'plotly' even if dev-python/plotly is installed
+#distutils_enable_sphinx docs dev-python/commonmark dev-python/recommonmark dev-python/numpydoc dev-python/jupyter-sphinx dev-python/plotly
+distutils_enable_tests pytest