summaryrefslogtreecommitdiff
path: root/dev-python/pydantic/pydantic-2.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydantic/pydantic-2.0.2.ebuild')
-rw-r--r--dev-python/pydantic/pydantic-2.0.2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pydantic/pydantic-2.0.2.ebuild b/dev-python/pydantic/pydantic-2.0.2.ebuild
index 8603e0f0b172..ef2d6ce65d34 100644
--- a/dev-python/pydantic/pydantic-2.0.2.ebuild
+++ b/dev-python/pydantic/pydantic-2.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~riscv"
RDEPEND="
>=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
@@ -40,6 +40,17 @@ python_test() {
# require pytest-examples
tests/test_docs.py
)
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_abc.py::test_model_subclassing_abstract_base_classes_without_implementation_raises_exception
+ tests/test_computed_fields.py::test_abstractmethod_missing
+ tests/test_edge_cases.py::test_abstractmethod_missing_for_all_decorators
+ tests/test_generics.py::test_partial_specification_name
+ tests/test_model_signature.py::test_annotated_field
+ )
+ ;;
+ esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p pytest_mock