summaryrefslogtreecommitdiff
path: root/dev-python/pycxx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest3
-rw-r--r--dev-python/pycxx/pycxx-7.1.7-r1.ebuild37
-rw-r--r--dev-python/pycxx/pycxx-7.1.8.ebuild37
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index c3923d312fc5..adc902621e56 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,3 +1,6 @@
DIST pycxx-7.1.7.tar.gz 156383 BLAKE2B 69a454615c9a7cdc57f4c357b9e3805821711bc48efb82e684da6066069ff0ee6af3b76911a705adb6f984969659441d331a8470061b514180ddf53f6494a33d SHA512 5439b2f72a7f04a628e7e93d093566654f3b4eafe78a7834005f86fb08e614f22f4d1fffb8d626e46cd56880ff7792e494ee3282b313ce668a7497d2bc1fbea9
+DIST pycxx-7.1.8.tar.gz 154789 BLAKE2B e4b635d4b53ae3fd0790d6eddcd465acfc5272213e9752e7c2a1840edddb66f09bc9617373246964859125a27dc82110de6b4f4ffa44c41c94c338c846490e47 SHA512 3c9c3a23dfa9777c6a48b8600e7336cbadb60080a1051071583d534ead6c691dd9d304613073d6fb0c632eb1703b043b4214826c0ae7bd4b2ca72203ec03c0a2
+EBUILD pycxx-7.1.7-r1.ebuild 977 BLAKE2B e563337f0e545c9c5a0e7f9dea5172c1db92ca65c84e7f41b3a2cdf5f3b0d7c7e4f437e3eb2672d133e30f0136c21d7f52dc80695e01205fcd6aaa33f59fb818 SHA512 74e69070ca5e03f33a980ea2454e567a03f2635a3f37539b29e599787e156ac70e076ff92490a747cb251fb86babf8f6faffdce3953d6d5095f466866761a837
EBUILD pycxx-7.1.7.ebuild 973 BLAKE2B 968456952d953c10d57161603b72144d2837ce0f0d78660fb7b61a0353acd8e513d967c4d4fbe66d31c0babbfa5fd736864c38847b296d8a346b7039a5d844e1 SHA512 5f94ef0d1116f5336b8ed952a50a35b2966f13b729d20e2079c8d4a4821ca06748ede093fde1d7ed7d483e22e9d18fcdb8ddcec6b8e4872737708d3da9b20db8
+EBUILD pycxx-7.1.8.ebuild 977 BLAKE2B e563337f0e545c9c5a0e7f9dea5172c1db92ca65c84e7f41b3a2cdf5f3b0d7c7e4f437e3eb2672d133e30f0136c21d7f52dc80695e01205fcd6aaa33f59fb818 SHA512 74e69070ca5e03f33a980ea2454e567a03f2635a3f37539b29e599787e156ac70e076ff92490a747cb251fb86babf8f6faffdce3953d6d5095f466866761a837
MISC metadata.xml 741 BLAKE2B 0704aeaef1fff687aa8374876e9d275a135d4ead7fabc938d8b3dc60954717fcf01bb79e8e9a72483184b13441d65294f41f7b5b0b19bebbf42c0934993723f4 SHA512 0b4f912fa2e38882bcaecede459f34270dd222a94bf70fa019e8de1eb1097c9c9016405b9b8a7933fd7839f11404a18c5e2ce7d4b4336a7121e86605903a8901
diff --git a/dev-python/pycxx/pycxx-7.1.7-r1.ebuild b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
new file mode 100644
index 000000000000..cadfdbb9e765
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..12} )
+# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pycxx/pycxx-7.1.8.ebuild b/dev-python/pycxx/pycxx-7.1.8.ebuild
new file mode 100644
index 000000000000..cadfdbb9e765
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..12} )
+# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}