summaryrefslogtreecommitdiff
path: root/dev-python/pycxx/pycxx-7.1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycxx/pycxx-7.1.8.ebuild')
-rw-r--r--dev-python/pycxx/pycxx-7.1.8.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pycxx/pycxx-7.1.8.ebuild b/dev-python/pycxx/pycxx-7.1.8.ebuild
index 104eb10e7890..c55a7897a81e 100644
--- a/dev-python/pycxx/pycxx-7.1.8.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.8.ebuild
@@ -10,7 +10,7 @@ DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
+HOMEPAGE="https://cxx.sourceforge.net"
SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
LICENSE="BSD"
@@ -18,6 +18,12 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc examples"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' 3.12)
+"
+
python_prepare_all() {
# Without this, pysvn fails.
# Src/Python3/cxxextensions.c: No such file or directory