summaryrefslogtreecommitdiff
path: root/dev-python/pycpio/pycpio-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycpio/pycpio-9999.ebuild')
-rw-r--r--dev-python/pycpio/pycpio-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pycpio/pycpio-9999.ebuild b/dev-python/pycpio/pycpio-9999.ebuild
new file mode 100644
index 000000000000..140af15820ae
--- /dev/null
+++ b/dev-python/pycpio/pycpio-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio"
+EGIT_REPO_URI="https://github.com/desultory/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/zenlib-9999[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/
+}