summaryrefslogtreecommitdiff
path: root/dev-python/pycountry/pycountry-18.5.26.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycountry/pycountry-18.5.26.ebuild')
-rw-r--r--dev-python/pycountry/pycountry-18.5.26.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pycountry/pycountry-18.5.26.ebuild b/dev-python/pycountry/pycountry-18.5.26.ebuild
new file mode 100644
index 000000000000..4f2beccae580
--- /dev/null
+++ b/dev-python/pycountry/pycountry-18.5.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null || die
+ if [[ ${EPYTHON} == pypy* ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ pytest -vv || die
+ popd > /dev/null || die
+}