summaryrefslogtreecommitdiff
path: root/dev-python/pycollada
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycollada')
-rw-r--r--dev-python/pycollada/Manifest5
-rw-r--r--dev-python/pycollada/pycollada-0.4.ebuild3
-rw-r--r--dev-python/pycollada/pycollada-9999.ebuild63
3 files changed, 4 insertions, 67 deletions
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
index 4c34f6111f99..b2ad4c7b4187 100644
--- a/dev-python/pycollada/Manifest
+++ b/dev-python/pycollada/Manifest
@@ -1,4 +1,3 @@
-DIST pycollada-0.4.tar.gz 519732 SHA256 62a69cce29759900cce0400dac8796d7210de1910dad4c60d4094248c7738121 SHA512 6e9569b858f2014aa08764d0bf328c8317b94edc91e99c2a7c97bf2355983555ea103012d6e6f197862cb3df113ca9263de18fc47edb3c60e74fa8e58b5ca8b0 WHIRLPOOL ce54dcb29cab7e1d97ac8c2eaa3718182373dfa79c7647c7c46f5a2afde88bf7832f98db4a89bdfb58964ccbab041787ac17a25dabc148e963e0739bac27780e
-EBUILD pycollada-0.4.ebuild 1222 BLAKE2B c16fc8a5a92d240c71df7a5546349ae97ce35125eb6de5da678e2bc5dae7b3f0a5008a04faa08317f0b695e557ee65415864b0105e306928f762a09f1d952e60 SHA512 2052333ded6165cda96290846334b38b0c34714a79eff0fe0bc42b450eb6c7259ab5788ecf1416bae55b3fa936cfcf4b5b2273b62305507cd32a1a1a36c839b6
-EBUILD pycollada-9999.ebuild 1190 BLAKE2B 50b768f6243d1f3b088a58089c76fb5bd45171d8e317e99b07babe4380c6afda18826ed5187cb43a70f6dbc165d00ba8c55e6b6147ef2143cedc56dedd711b63 SHA512 b0b3142eb3117f4e0db3a6606eae1768ef623c25886f5a23f0b5172a5798718f8697df94be2646a89e6e530951c1c22d549c3904954f5f7b95f193ce5d0a8ed8
+DIST pycollada-0.4.tar.gz 519732 BLAKE2B 9fd9b7ca369943cb6b2d9960b343ed39a9e578bb2e94c06d5e7c027a814220b13ff66d6137371edab150befd4b4301e9cf5420385f7dd3ad72dc11a38c38afa9 SHA512 6e9569b858f2014aa08764d0bf328c8317b94edc91e99c2a7c97bf2355983555ea103012d6e6f197862cb3df113ca9263de18fc47edb3c60e74fa8e58b5ca8b0
+EBUILD pycollada-0.4.ebuild 1263 BLAKE2B 5ec572af9cf78ad57a863e26f0f5e60cfb84db0404b284efc45ba85c03fae3f896840a82bcd3a8e3e25c1e2e939c93847b33c9675f08a14e9876e1c4ddab29d1 SHA512 f220da283c4bfca03b0c22c14f9a7a9693e8f50dd271392252f435cbf4e8eb3a813d7928807e57a3c572912cda156c7e27b18d4e1e5f7c335b9a392baddf1834
MISC metadata.xml 327 BLAKE2B f1ea87e797a3f8379e6f5cc0b84b7fff48f28b56b71ba4b17fa1a12cc8148dd2a09176ae5fb1f727f1cb0a260cb395f184c2a1bb4109f5450e8bc77124531f12 SHA512 a413c6d76aa3a80cf2f32c4cc75760c0574019eff6d381c1f46aefe4bc7924e59f28d593691b2ac7bb0a7afa7fcdb11a264f3bbc600bfab61148634282307886
diff --git a/dev-python/pycollada/pycollada-0.4.ebuild b/dev-python/pycollada/pycollada-0.4.ebuild
index 2f8bf9700865..91e85d338acd 100644
--- a/dev-python/pycollada/pycollada-0.4.ebuild
+++ b/dev-python/pycollada/pycollada-0.4.ebuild
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"
-DEPEND="doc? ( dev-python/sphinx )
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
test? ( dev-python/python-dateutil )"
RDEPEND="dev-python/numpy
dev-python/lxml
diff --git a/dev-python/pycollada/pycollada-9999.ebuild b/dev-python/pycollada/pycollada-9999.ebuild
deleted file mode 100644
index f0b16d863454..000000000000
--- a/dev-python/pycollada/pycollada-9999.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_MULTIPLE_ABI=1
-
-inherit distutils-r1 git-2
-
-DESCRIPTION="python library for reading and writing collada documents"
-HOMEPAGE="https://pycollada.github.com/"
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc examples test"
-
-DEPEND="doc? ( dev-python/sphinx )
- test? ( dev-python/python-dateutil )"
-RDEPEND="dev-python/numpy
- dev-python/lxml
- >=dev-python/python-dateutil-2.0"
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc ; then
- pushd docs
- emake html
- popd
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-
- if use doc ; then
- pushd docs/_build/html
- dohtml -r *
- popd
- fi
-
- if use examples ; then
- insinto /usr/share/${P}/
- doins -r examples
- fi
-
- install_test_data() {
- insinto $(python_get_sitedir)/collada/tests/
- doins -r collada/tests/data
- }
- python_foreach_impl install_test_data
-}
-
-src_test() {
- test_collada() {
- for script in "${S}"/collada/tests/*.py ; do
- PYTHONPATH="${S}" $EPYTHON "${script}"
- done
- }
- python_foreach_impl test_collada
-}