summaryrefslogtreecommitdiff
path: root/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild')
-rw-r--r--dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild b/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
index cfe07333d595..545c1fc46ab7 100644
--- a/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
+++ b/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
@@ -4,12 +4,16 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
MY_P=${P/_p/.post}
DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
-HOMEPAGE="https://github.com/fonttools/pyclipper"
+HOMEPAGE="
+ https://github.com/fonttools/pyclipper/
+ https://pypi.org/project/pyclipper/
+"
SRC_URI="
https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz
-> ${MY_P}.gh.tar.gz
@@ -28,7 +32,4 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- distutils-r1_src_prepare
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
-}
+export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"