summaryrefslogtreecommitdiff
path: root/dev-python/pycares/pycares-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycares/pycares-4.3.0.ebuild')
-rw-r--r--dev-python/pycares/pycares-4.3.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pycares/pycares-4.3.0.ebuild b/dev-python/pycares/pycares-4.3.0.ebuild
index 19ac39d76e8f..65783928aa52 100644
--- a/dev-python/pycares/pycares-4.3.0.ebuild
+++ b/dev-python/pycares/pycares-4.3.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -32,7 +32,9 @@ DEPEND="
net-dns/c-ares:=
"
BDEPEND="
- virtual/python-cffi[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
"
RDEPEND="
dev-python/idna[${PYTHON_USEDEP}]
@@ -45,6 +47,12 @@ BDEPEND+="
)
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # regression due to Internet changing (probably)
+ # https://github.com/saghul/pycares/issues/187
+ tests/test_all.py::DNSTest::test_query_class_chaos
+)
export PYCARES_USE_SYSTEM_LIB=1